データ分析入門(5)
第5章 JMPのインストールと基本操作
廣野元久
1
1 WindowsとJMPの基本操作
1.1 Windowsの起動と終了
1.2マウスの使い方
右,左クリック,ダブルクリック,ドラッグ
ドラッグ&ドロップ
1.3ウインドウの基本操作
1.4ヘルプ
1.5エクスプローラ
1.6Windows利用の際の注意点
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
2/38
1.1 Windowsの起動と終了
ログオンにはパスワードが必要
ログオフはシャットダウンを選択
むやみにリセットするとシステムファイルが
破損するので注意する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
3/38
1.3 ウインドウの基本操作
タイトルバー
最大化
最小化 ボタン
タスクバー
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
4/38
2.JMP のインストールの手順
CDROMをPCに取りつけ
JMPのCDをセットする
画面の指示に従う
Cドライブにインストール
自動でショートカットが作成される
PCの画面からJMP を起動できる
注) SFCの学生はネットワークからダウンロードする
詳しくは配布資料を読むこと
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
5/38
ショートカット作成(1):手動の場合
1.JMP実行ファイルを右クリックして
2.をクリック
3.JMPのフォルダ内にショート
カットができる
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
6/38
ショートカット作成(2):手動の場合
クリックしたままで、デスクトップへドロップする
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
7/38
3 JMPの基本操作(1)
3.1サンプルデータのダウンロード
3.2JMPの起動から終了まで
3.2.1 JMP の起動
3.2.2 サンプルデータのロード
3.2.3 ヒストグラムの出力
3.2.4出力内容のコピー
3.2.5JMP の終了
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
8/38
3 JMPの基本操作(2)
3.3データの入力と操作
3.3.1データの入力
3.3.2ヒストグラムの作成
3.3.3新規フォルダの作成,入力データの保存
3.4外部データの読み込み
3.5リポートの保存と印刷
3.5.1Wordでリポートを保存しよう
3.5.2プリンターで印刷しよう
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
9/38
3 JMPの基本操作(3)
4.ヘルプを活用しよう
現バージョンは日本語
5.総合練習問題
興味ある人、操作に不安な人は実行する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
10/38
3.1 サンプルデータのダウンロード
サンプルデータをダウンロードする
データ分析のホームページのダウンロードから
http://www.dsci.sfc.keio.ac.jp/
安全の為にバックアップフロッピーを作成する
DAsampleというフォルダをつくり,
Program Files フォルダ内の
SAS Institute内の
JMP フォルダに移動する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
11/38
3.1 DAsampleフォルダの作成
JMP ウインドウの上部のファイルを選択
メニューの“新規作成”からフォルダを選択
1.クリック
したまま
2.クリックを離す
(ドロップ)
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
12/38
3.1 ‘ Dasampleフォルダの作成
このフォルダをダブルクリックして開く
JMP のウインドウを閉じる
同様にMyDataフォルダを作っておこう
2.新しいフォルダ
の所をもう1回
左クリック
3.“DAsample”という名前をつける
1.クリック
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
13/38
中外製薬ではパブリックホルダー
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
14/38
3.2 JMP の起動から終了まで(1)
3.2.1 JMPの起動(JMPのアイコンをダブル
クリックする)
慣れると便利な
スターターは
授業では
使わない
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
15/38
3.2 JMP の起動から終了まで(2)
3.2.2 サンプルデータのロード
2.サンプルデータ
フォルダをクリック
3.開くボタンをクリック
4.ビッグクラスを選択
1.ファイルをクリック
5.開くボタンをクリック
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
16/38
JMPのサンプルデータのフォルダ
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
17/38
3.2 JMPの起動から終了まで(3)
3.2.3 ヒストグラムの出力
1.メニューの分析(A)
をクリックする
2.一変量の分布を
クリックする
データテーブル
パネル
データグリッド
データテーブル
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
18/38
3.2 JMPの起動から終了まで(4)
3.OKボタンをクリック
2.このボタンをクリック
1.選択する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
19/38
3.2 JMPの起動から終了まで(5)
ヒストグラムの完成
統計手法などのオプションが隠れている
ここ▼を
クリックす
ると非表
示
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
20/38
3.2 JMPの起動から終了まで(6)
3.2.4 出力内容のコピー
1.分析結果のウインドウをアクティブにする
2.編集メニューをクリックして
ドラッグ&ドロップ
3.ジャーナルで離す
4.ジャーナルのウインドウが
表示される
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
21/38
3.2 JMPの起動から終了まで(7)
ジャーナルをMy Documentsに保存する
1.ファイルメニューをクリック
2.名前を付けて保存で
ドロップ
3.マイドキュメント
フォルダを選び
4.ファイルな名を入力
5.リッチテキスト形式
を指定
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
22/38
3.2 JMPの起動から終了まで(8)
報告書を作成する
1.Wordを起動する
4.対象ファイルを選ぶ
2.ファイルメニューから開くをクリック 5.開くをクリック
3.リッチテキスト形式を選ぶ
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
23/38
3.2 JMPの起動から終了まで(9)
Wordで編集,あるいはレポートの作成
1.このグラフの上で
右クリックすると
2.メニューが表示される
3.コピーをクリック
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
24/38
3.2 JMPの起動から終了まで(10)
Wordで編集,あるいはレポートの作成
1.新しいWord文章を作成する
2.適当な位置で右クリックして
メニューを表示
3.貼り付けをクリック
4.指定したヒストグラムだけが
貼り付く
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
25/38
3.2 JMPの起動から終了まで(11)
JMPから直接張り付け
1.十字のマークを
クリックする
2.マウスの表示が十字に
なったのを確認
3. 領域を指定
4.指定された領域の色が
反転する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
26/38
3.2 JMPの起動から終了まで(12)
JMPから直接張り付け
1.編集メニューのコピー
をクリック
テキストとしてコピーを
選ぶと文字情報が
コピーされる
2.Wordの編集の
貼り付けをクリック
3.グラフが文章に
貼り付く
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
27/38
良いレポート
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
28/38
3.2 JMPの起動から終了まで(13)
3.2.5 JMP INの終了
1.JMP 内のウィンドウを
全て閉じて
2.ファイルメニューの
終了をクリック
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
29/38
3.3 データの入力と操作(1)
3.3.1 データの入力
1.ファイルメニューの
新規作成から
データテーブルをクリック
2.新しいデータテーブルが
表示される
3.ダブルクリックすると
ダイアログが表示される
4.必要な行数を入力
5.OKボタンをクリック
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
30/38
3.3 データの入力と操作(2)
3.3.1 データの入力
1.ダブルクリック
ダブルクリックは少し
コツがいる
2.列情報の
ダイアログが表示
ウインドウ上側の列メニュー
をクリックしても同じことができる
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
31/38
3.3 データの入力と操作(3)
データタイプ
変量名
数値データ
文字データ
行の属性
データ種類
各セルに入力できる
最大文字,桁数
C:連続尺度(比例尺度,間隔尺度)
O:順序尺度
N:名義尺度
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
32/38
3.3 データの入力と操作(4)
3.3.2 ヒストグラムの作成
3.3.3新規フォルダの作成,入力データの保存
新規フォルダの作成
ファイルの保存
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
33/38
3.4 外部データ(Excel)の読み込み
1.ファイルメニューの
開くをクリック
2.外部データのある
フォルダを指定
3.Excelファイルの
拡張子を選ぶ
4.全てのExcelのシート
が読み込まれる
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
34/38
テキスト形式のデータの読み込み
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
35/38
CSVファイルの読み込み
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
36/38
3.5 リポートの保存と印刷
3.5.1 Wordでリポートを保存しよう
Wordはテキストファイル形式ではない
Wordのプログラムがないと読めない
3.5.2自分のプリンタで印刷しよう
ハードウエアの設定が必要(取説を参照)
複数のプリンタに接続可能な場合には,プリンタ
の違いによってレイアウトが変わるので注
意!!
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
37/38
4.ヘルプを活用しよう
最近のソフトには
プログラム内にヘルプが用意されている
ヘルプは多くの場合,階層構造
目次からキーワード
検索する
第5章 JMPのインストールと基本操作
廣野元久 &高橋行雄
38/38
ダウンロード

クリック - ODN