ImageJのマクロを用いた
顕微鏡等の画像の定量化
1
ImageJとは

NIHで開発された画像解析ソフト。

無料のオープンソースソフトウェアである。

もともとMacintosh用のNIH Imageというソフ
トウェアがあったが、これをJava言語で書き
なおしたもの。これによりどんなOSでも走
る。

マクロプログラミングまたはJavaでプラグイ
ンの作成(機能の追加)が可能。

オープンソースであるため、世界中にユー
ザーがおりプラグインも多く公開されている。
2
ユーザーマニュアル等
(http://tinyurl.com/seika-cにリンクがあります)





ImageJ Documentationサイト(Tutorial, 応用例,
Wikiなど)
ImageJ User Guide
ImageJ Macro Language
マニュアルの日本語訳
概要の日本語訳
3
ImageJの直接操作による画像
解析
4
画像の開き方
1) File>Openで画像ファイルを選択
 2) Ctrl-Oで同様にファイル選択
 3) ファイルをImageJのアイコンまたはメニュー
バーにドラッグ
 複数の画像を同時に開くことができる。また
、画像処理により新たに作成した画像も別ウ
ィンドウとなることがある。すべての操作は
選択状態となっているウィンドウ(アクティ
ブウィンドウ)に対して行われるので、どの
画像が選択されているかに常に注意する。

5
画像の種類





ImageJではRGBカラー画像およびグレースケール画像
(モノクロ画像)を扱うことができる。
RGB画像はRed,Green,Blueの三色がそれぞれ8ビットで
表現されている。
グレースケール画像としては8ビット(0~255の256段
階)、16ビット(0~65535)、32ビット(符号付き浮動小
数点)の画像が扱える。
画像処理の過程で二値化(Binary)画像も扱うが、こ
れはグレースケール画像の形式のまま、白と黒だけで
描かれた画像である。
RGBの三色を別々のレイヤーで扱う場合、これを特に
コンポジット画像と呼ぶ。
6
画像形式の変換
 各画像ウィンドウの上部に画像サイズ、画像形式、ファイ
ルサイズが表示されている。
 画像形式の変換はImage>Typeで行う。例えばRGB画像の
色情報を破棄してグレースケール(8ビット)にする場合。
 RGBの三色を分解してそれぞれをグレースケール画像にす
るときは、Image>Color>Split Channels
 逆に3枚(または他の枚数)のグレースケール画像をそれ
ぞれ赤、緑、青としてRGB画像にするには
Image>Color>Merge Channels
 Merge Channelsではコンポジット画像にもできる。これは
複数の画像を一つに重ねて色をつけて表示する形式。
Image>Color>Channels Toolで表示するチャネルを選べる
。
7
シュードカラー表示
グレースケール画像に、見やすいように色をつけて表
示することができる。つまり、ピクセル値(例えば8
ビット画像であれば0-255の値)のそれぞれに色を対
応させる。
 この対応関係のことをLookup Table (LUT)という。
 多数のLUTが用意されており、Image>Lookup Tablesで
選ぶことができる。
 例えば、Greenを選ぶと、グレースケールの明るさに
比例した明るさの緑一色の表示に変わる。
 LUTの実際の色は、Image>Color>Display LUTsにより一
覧で表示させることができる。

8
スタック画像
 一連の画像が一まとめになっている場合がある。例え
ば一定時間ごとに撮影した顕微鏡写真、フォーカス面
を変えながら取り込んだ顕微鏡の画像、ムービー画像
など。
 これらの画像はImageJではスタック画像として扱う。
 連番つきの一連の画像ファイル(例えばimg001.jpg,
img002.jpg, img002.jpg ....など)の場合、
File>Import>Image Sequence...で開く。ムービーの場合は
単にFile>Open。
 画像ウィンドウ下のスライドを動かすと表示画像が切
り替わる。その左の をクリックするとムービー再生
される。Image>Stacks>Tools>Start Animationでも同じ。
 スタック画像に対するいろいろな操作はImage>Stacks>
以下にまとめられている。
9
画像の複製や保存





Image/Duplicate(Shift-Ctrl-D)でアクティブウィンド
ウの画像が複製され新しいウィンドウが開く。
Image/Renameでは画像の名前を変更。
File/Saveで保存。 File/Save As...で画像ファイルの名
前と形式を指定して保存。
ムービーやスタック画像の場合はFile/Save As... で
AVIを指定するとムービー形式で保存できる。Image
sequenceを指定するとファイル名に連番のついた一
連の画像ファイルとして保存される。
Image/Transform/RotateやImage/Zoomは自明なので
試してみる。↑キー、↓キーでズームできるので覚
えておくと便利。
10
Windowコマンド
メニューバーのWindowの下にあるコマンド
のショートカットを覚えておくとよい。
 Ctrl-]ですべてのウィンドウを表示。
 tabキーでアクティブウィンドウを背後に移
動し、別のウィンドウがアクティブになる
。Tabを繰り返し押すと開いているウィンド
ウが順次アクティブになる。

11
ステータスバー、拡大縮小

マウスが画像の上にあるときにはステータスバーにカーソル下の
ピクセルの座標とピクセル値(輝度)が表示される。

ステータスバーをクリックすると現在使用中のメモリ、使用可能
メモリ等が表示される。
ステータスバー
虫眼鏡ツール
スクロールツール

虫眼鏡ツールを選択した状態で画像をクリックすると画像表示倍
率が一段階拡大される。右クリックまたはCtrlを押しながらのク
リックで画像が縮小される。虫眼鏡ツールをダブルクリックする
ともとの大きさに戻る。↑、↓キーでもズームイン、ズ-ムアウト
ができる。

ウィンドウのサイズより画像が大きくなっている時には、スクロ
ールツールで画像の表示部分を移動させることができる。他のツ
ールを使用中でも、スペースを押すと一時的にスクロールツール
12
が使える。
画像の明るさの調整




Image>Adjust>Brightness/Contrast...
出てくるウィンドウで画像の輝度レンジを調整。
グレースケール画像の場合、Setでウィンドウの明る
さは変わるが、画像データの数値は変わらない。
Resetでもとに戻る。Applyにより画像のピクセルの
輝度値が変わる。適用後はもとに戻せない。
RGB画像の場合は上記いずれの処理でも直ちに画像
の輝度値が変更される。
Image>Adjust>Color Balance...はRGB画像に対して
色ごとに輝度調整を行う。色のバランスを変えたり
一色だけにしたりできる。使い方は上と同様。
13
選択枠(1)




ツールバーには四角、
円、直線などの選択
ツールがあり、それを
使って画像の一部を選
択できる。▼がついて
いるものは右クリック
で種類を変えられる。
選択は一度に一か所のみ。
選択枠はドラッグにより移動できる(マウスが矢印の状態で行う
)。矢印キーでも移動できる。マウスが手の形の状態でドラッグ
すると枠の大きさが変わる。Altを押しながら矢印キーを使っても
大きさを変えられる。
選択枠を選択時には、
枠の位置(通常左上角の
ピクセル座標)とサイ
ズなど(枠の種類によ
り内容は異なる)がス
テータスバーに表示さ
14
れる。
選択枠(2)











四角形ツール:四角形を選択。
楕円ツール:縦または横に長い楕円を選択。
ブラシツール(楕円ツールを右クリック):選択枠のまわりから掃
くと選択枠が削られ、中から掃くと選択枠が拡がる。
多角形ツール:多角形の角をクリックしていく。
フリーハンドツール:なぞった通り。最後は自動的に閉じる。
線ツール:直線、多角の線、フリーハンドが選べる。
角ツール:角度を測定するためのもの。
テキストツール:文字を記入する。フォントの変更は
Edit>Options>Font。
領域が選択されていると、画像操作はこの領域に対して行われる。
また、領域内の画像のコピーペーストなども可能。Edit>Clearで選
択枠の中がBackground colorになり、 Edit>FillでForeground colorに
なる。周りの領域をBackground colorにするにはEdit>Clear
Outside、周りの領域がいらなければImage>Crop。
Foreground color, Background colorはEdit>Options>Colorsで変更する
。
15
Edit>Drawで選択枠の枠がForeground colorで描画される。
選択枠(3)

選択枠はFile>Save As>Selectionで保存できる。

選択枠を別の画像に移すには移動先の画像をアクティ
ブにし、Edit>Selection>Restore Selection
選択枠を消すときにはEdit>Selection>Select None
(Ctrl-Shift-A)
複数の選択枠で作業するときにはAnalyze>Tools>ROI
Manager


16
サイズキャリブレーション

Analyze>Set Scaleでサイズのキャリブ
レーションを行っておくと計測の際に
mm等の実際の長さで結果が表示され
る。キャリブレーションを行わない場
合はピクセル単位で計測する。
17
計測、ラインプロット

選択枠に対して計測を行う場合はまずAnalyze>Set
Measurements...で測定項目を選ぶ。次に
Analyze>Measure (Ctrl-M)で測定結果がResultsウィン
ドウに表示される。

ラインプロットは直線の選択枠を選択した際に実行で
きる。Analyze>Plot Profileで線に沿ったピクセル強度
の変化がプロットされる。
四角選択枠を選んで同様
の操作をすると、四角を
縦に平均した値を横に辿
って測定したプロットが
描かれる。

18
画像の二値化

手動で選択枠で囲む代わりに自動的に対象物を認識させるためには
、画像の二値化を行う。

二値化とは、グレースケール画像に対し、一定の明るさの範囲(
Threshold)を設定する作業。例えば一定レベルより明るいピクセル
を対象物とする。
設定はImage>Adjust>Threshold (Shift-Ctrl-T)で行う。バックグラ
ウンドが暗く対象物が明るい画像の場合はDark backgroundにチェッ
クを入れる。選択範囲が赤で示され、スライドバーを動かすとその
範囲が変化する(何も起こらないときは画像がRGBになっていない
か確認すること)。
Autoでは自動的にThresholdが設定される(最初はAutoになってい
る)。"Default"のプルダウンでAutoの計算法を変えられる。
Setを押すとその時のスライドバーの値でThresholdが設定され、対
象物の計測が可能となる(Autoのままなら何もしなくてよい)。
Setでは画像のピクセル値は変化しない。
Resetを押すとThreshold設定が解除され、赤色がなくなる。
Applyを押すと画像のピクセル値が変化し、選択範囲が白の二値化
画像となる。
二値化画像を白黒反転させたいときはEdit>Invert 。
19






二値化画像のプロセシング









Process>Binaryの下のコマンドで二値化画像のプロセシングができる
。
Process>Binary>OptionsのBlack backgroundをチェックすると対象物は
白、そうでないと対象物は黒とみなされる。
Process>Binary>Dilate:対象物を1ピクセル太らせる。
Process>Binary>Erode:対象物を1ピクセル痩せさせる。
Process>Binary>Open: Erode→Dilate(細いところがなくなる)
Process>Binary>Close: Dilate→Erode(小さい隙間がなくなる)
Dilate, Erode, Open, CloseはProcess>Binary>OptionsのIterationsで繰り
返し回数を設定できる。
Process>Binary>Fill Holes:穴を埋める。
Process>Binary>Skeletonize:線になるまで痩せさせる
Process>Repeat Command(Shift-Ctrl-R):前回操作の繰り返し
20
粒子分析
バイナリー画像またはThresholdが設定されている画像に
ついて、対象物を認識し、数や大きさを計測する。バイ
ナリー画像はデフォルトでは対象物が黒と仮定される。
白い対象物を扱う場合にはImage>Adjust>Threshold
(Shift-Ctrl-T)でDark backgroundを選んでThreshold設定して
おく。
 まずAnalyze>Set Measurementsで測定項目を設定する。
 Analyze>Analyze Particlesで開くウィンドウで以下を設定。

対象物と認識されるための面積の範囲
対象物と認識されるための真円度の範囲
選択結果の表示形式
21
粒子分析
22
測定結果
Analyze ParticleでDisplay resultsをチェックしておくと、測
定結果がResultsウィンドウに表示される。
 Clear Resultsをチェックしておくと、Resultsに記録されて
いた前回までの結果をクリアするが、チェックしないと
前回までの結果に追加して結果が表示される。
 結果の数値をファイルに保存するためには、Resultsウィ
ンドウのFile>Save As...またはImageJメニューバーの
File>Save As>Measurements...を用いる。
 Edit>Options>Input/OutputでFile Extention for Tablesを.xls
か.txtにすることによりエクセルファイルとして保存する
かテキストファイルとして保存するかを選べる。
 ResultsウィンドウのEdit>Distributionでサイズ分布のヒス
トグラムが表示される。これもファイルに保存できる。

23
ヒストグラム

開いている画像の各ピクセルの輝度分布を表示す
るにはAnalyze>Histogram

輝度分布のほかに全ピクセル数や平均輝度なども
表示される。
ヒストグラム上に
マウスを置くとそ
の位置の値が表示
される。
条件設定画面はAlt-H
で表示される。


結果の数値をResultウィンドウで表示
結果の数値をResultウィンドウで表示
縦軸をLogスケールにする
24
フィルタ(1)

一定の規則で画像を処理し、バックグラウンドを
除いたり平滑化したり、細かいところを際立たせ
たりする処理をフィルタリングという。

Process>Smoothで画像が平滑化される
。それぞれのピクセルの輝度値をその
周りの3×3のピクセルの平均値で置き
換える。右のマトリックスと同じ。

明るさの変化を抽出したい場合、例え
ば右に行くにつれて明るくなる場所を
みつけるには右のマトリックスを使う
(微分フィルタ)。(ImageJで直接的
に準備されてはいない。)
1/9
1/9
1/9
1/9
1/9
1/9
1/9
1/9
1/9
-1
0
1
-1
0
1
-1
0
1
25
フィルタ(2)


Process>Find Edgesはエッジをみつ
ける。右の二つのマトリックスを用い
て縦と横の変化率を抽出する。それぞ
れの値の二乗を足すことにより中央の
ピクセルの輝度を決める。
Process>Sharpenでは、詳細を強調し、
コントラストを増強する。右のマトリ
ックスが使われている。
-1
-1
-1
-1
12
-1
-1
-1
-1
=
0
0
0
0
13
0
0
0
0
―
1
0
-1
2
0
-2
1
0
-1
1
2
1
0
0
0
-1
-2
-1
-1
-1
-1
-1
12
-1
-1
-1
-1
1
1
1
1
1
1
1
1
1
26
フィルタ(3)





マトリックス(Kernel)を自分
で作る場合は
Process>Filters>Convolve...。
右のように自由なKernelを入力
して実行させることができる。
Process>Filters>Gaussian Blurはガ
ウス曲線(正規分布型)の関数
で平滑化を行う。
Process>Filters>Mean...は指定した半径の近隣ピクセ
ルの平均値でピクセルの輝度を置き換えることによ
る平滑化。
Process>Filters>Median...は指定した半径の近隣ピクセ
ルの中央値で置き換える。
同様にProcess>Filters>Median...は最小値、
Process>Filters>Maximum...は最大値で置き換える。 27
画像演算




Process>Mathは画像に一定の演算を施す。例えばAddは入力し
た数値をすべてのピクセルに足す
Process>Image Calculatorは二つの画像間の対応するピクセル同
士で演算を行う。例えば
Add: image1 = image1 + image2
Subtract: image1 = image1 - image2
Multiply: image1 = image1 * image2
32bitにチェックを入れると結果にマイナスの値も許される。
32bit画像はImage>Adjust>Brightness and Contrastでレンジを設定
した上でImage>Typeで8bitにもどす。
Edit>Paste Control…でも画像演算が行える。この場合は一方の
画像をコピーし、他方にペーストする際に演算種類を選ぶ。
Process>Subtract Backgroundはローリングボールアルゴリズムで
不均一なバックグラウンドを除去する。
28
平滑化と画像演算によるバックグラ
ウンド除去
平滑化
この部分を引く
29
フーリエフィルタ

すべての曲線は異なる周波数の波の重ね合わせで書けるという
原理を応用し、まず波に分解する(フーリエ変換)。(実際は
これを縦横の二次元で行う)→ 特定の周波数の範囲の波を除
いた上でもとに戻す(逆フーリエ変換)。
Process>FFT>Bandpass Filterがこの一連の操作を行う。

低周波(ゆっくりした波)を除いて高周波(細かい波)を残す
操作をハイパスフィルター(バックグラウンド除去の効果)、
逆の操作をローパスフィルター(平滑化の効果)という。
= +
+
+ ・・・
30
疑似カラー(シュードカラー)




グレースケール画像において、明暗の定量的な差が重
要な場合に疑似カラーでそれを視覚化することができ
る。
0-255のピクセル値が異なる色に対応させられる。対
応の規則をLookup table(LUT)という。例えば0→青、
255→赤など。この間が段階的に変化する。
Image>Lookup Tablesから適切なLUTを選ぶとアクティ
ブなグレー画像に疑似カラーが適用される。何も画像
が開いていないとそのLUT の0-255に対応する色が表
示される。
rsb.info.nih.gov/ij/download/luts/からさらに多くのLUTを
ダウンロード可能。このページの92 LUTs in a stack.tif
をダウンロードしてImageJで開くとLUTの色が一覧で
表示される。各LUT個別のダウンロードも一括ダウン
ロード(luts.zip)も可能。
31
スタック操作
Image>Stacks下にスタック操作の各コマンドがある。
多くは自明であろう。
 Image>Stacks>Make Montageはスタックの各画像を並べ
て表示する。
 Image>Stacks>Z Projectはスタックを重ねて一枚の画像
にする。例えばZ軸スライス(顕微鏡の焦点面を変え
て取得した一連の画像)のスタックであれば、上から
投影した図ができる。途中、画像の合成法(平均値、
最大値、合計値など)を指定する。
 Image>Stacks>3D ProjectはZ軸スライスのスタック画像
を用い、サンプルを回転させた画像を作る。回転方向
、角度等を指定する。
 Start Animationは動画として再生する。ショートカッ
トは\。もう一度\を押すと止まる。

32
ハイパースタック操作
xyzt画像やxyct画像などが扱える。すなわち異
なる Z(焦点面)、t(時刻)、c(カラー)を
持つ一連のxy平面の画像が集まったもの。
 Image>Hyperstacks>Hyperstack to Stackは二次元
の番号を持っていたハイパースタックを一列
に並べて単なるスタックと変換する。
 Image>Hyperstacks>Stack to Hyperstackはその逆
。
 Image>Hyperstacks>Reduce Dimensionalityはハ
イパースタックから特定のZあるいは特定のT
だけを抽出したスタック画像を作る。

33
ImageJマクロプログラミング
34
マクロの作成と自動記録




新しくマクロを作成するためのエディタを開くには、
Plugins>New>Macro。
既存のマクロを開いて修正するときはPlugins>Macros>Edit
マクロの自動記録を行うためには、
1) Plugins>Macros>RecordでRecorderウィンドウが開くの
で、一連の操作を行う。操作ごとにRecorderウィンドウ
にマクロ命令が書かれる。
2) 終わったらCreateをクリックするとエディタ画面が開
く。
3) 必要な修正を施し、エディタウィンドウのFile>Save As
で名前をつけ、拡張子を.txtまたは.ijmとして保存する。
ImageJフォルダのpluginフォルダに保存した.ijmマクロおよ
びファイル名に_(アンダースコア)が含まれる.txtマクロは
ImageJ起動時に自動的にPluginsメニューに表示される。
35
マクロの実行
マクロエディタ上のマクロはエディタウィンドウの
Macros>Run Macroで実行できる(ショートカットキ
ー Ctrl-R)。
 Pluginsメニューに表示されているマクロはPlugin>マ
クロの名前 を選択するだけで実行できる。
 保存されている他のマクロはPlugin>Macros>Run...で
ファイルを選択して実行。
 Plugin>Macros>Install...を行うと、 Plugin>Macros>の下
に表示されるようになるので、以後Plugin>Macros>マ
クロの名前 で実行できる。


マクロへのショートカットをツールバーに追加した
りアイコンのワンクリックで実行するようにもでき
る。Macroのマニュアル参照。
36
マクロのデバッグ

マクロエディタ画面のMacros>Function Finderで既定関数の検
索ができる。

実行時にエラーで止まった時には、コードの何行目に問題が
あったかと問題点が表示される。ボックスにチェックを入れ
ておくとMacroデバッガウィンドウが開く。 Edit>Go to Line
で行番号を入力すると指摘された行にカーソルが移る。
Debug>Debug Macroでデバッグウィンドウが開きデバッグ中
になる。デバッガウィンドウには変数の値がリアルタイムで
表示される。また、この状態では、Debug>Step(ショートカ
ットキーCtrl-E)で一行ずつ実行させたりDebug>Traceでゆっ
くり順次実行させたり(ショートカットCtrl-T)より早く順
次実行させたり(ショートカットCtrl-shift-T)できる。この
際にもデバッガウィンドウには変数の値が逐一アップデート
されるので実行順や問題点が確認できる。実行途中でもショ
ートカットキーで再生速度が変更できる
デバッグ中に、特定の行をクリックしてからDebug>Run to
Insertion Pointを選択するとその行まで実行される。


37
文

マクロの命令は文の並びである。文の最後にはセミコロ
ン(;)をつける。
変数
ImageJマクロの変数は「タイプレス」、つまり整数とか文
字とかの種別を持たない。使用の前に宣言する必要もな
い。その時その時で違う種類のデータを保持することが
できる。
 大文字と小文字は区別される。例えばAとaは別の変数と
して扱われる。
 例:v = 1.23;
print(v);
v = "a string";
print(v);
("log"ウィンドウに
1.23
38
a string
と表示される。

配列
配列とは添え字の番号で指定される一連の変数(要素と呼ぶ
)がセットになったもの。配列の添え字は[]で囲む。
 配列の要素数は.lengthで与えられる。例えば配列vの要素の
数はv.length。
 newArray(size)でsizeの数の要素を持つ配列が作成される。ま
たは、各要素の内容を与えて作成することもできる。
例:v = newArray(1,4,7);
v = newArray("a","b","c");
v = newArray(10);
v[1] = 5.02;
print(v[1]);


二次元の配列はサポートされていない。一次元の配列で二次
元配列を表現するしかない。
例: a=newArray(xmax*ymax);
value=a[x+y*xmax];
39
演算子
+
加算
==
等しい
-
減算
>
より大
*
乗算
>=
以上
/
除算
<
より小
%
余り
<=
以下
+
文字の連結
!
..でない
!=
等しくない
&&
AND
||
OR
++
1増やす
--
1減らす
=
代入
+=, -=, *=, /=
演算子付き値の代
入
40
If文
ある条件が満たされたときのみ一定の処理をする、という命令の書き方。
 if (condition) {
VBAでは
statement(s)
If condition Then
}
statement(s)
 if (condition) {
End If
statement(s)
} else {
If condition Then
statement(s)
statement(s)
}
Else
statement(s)
 if (condition) {
End If
statement(s)
} else if (condition){
If condition Then
statement(s)
statement(s)
} else {
ElseIf condition Then
statement(s)
statement(s)
}
Else
if (nImages==0)
statement(s)
print("No images are open");
End If
else
だった。
print("The image title is " + getTitle);
({}がないことに注意。{ }内に書くべき命令が一行ならこういう書き方もで
きる。; にも注意。getTitle()はアクティブな画像のタイトルを取得する既定
関数。)
41
例を手入力して実行してみること。いろいろ変えてみる。
For文
継続のための条件
初期設定
各回終了後の処理
For文の例
VBAでは
for (i=0; i<10; i++) {
For i = 0 To 10
......
j = 10*i;
Next i
print(j);
だった。
}
iを1から9まで増やしながら{}内の処理を実
VBAでは
行する。
For i = 0 To 90 Step 10
 for (i=0; i<=90; i+=10)
......
Next i
print(i);
だった。
これも一行だけの場合の記述。
i+=10は i=i+10と同じ意味。
 これも自分で実行してみる。

42
他のループ文
while文
i = 0;
while (i<=90) {
print(i);
i = i + 10;
}
 do-while文
i = 0;
do {
print(i);
i = i + 10;
} while (i<=90);

いずれもwhileのあとの条件が満たされる限り
{ }内の処理(=ループと言う)を繰り返す。
43
ImageJマクロビルトイン関数
ビルトイン関数の一覧は演習Webサイトの
ImageJ Macro Language (pdfまたはWeb版)からリンクされ
ているマクロマニュアルの最後の
"Built-in Macro Functions"にあるので適宜参照。
44
run関数など(1)

run("command"[, "options"]): メニューコマンドを実行する
。オプションはダイアログボックスに自動的に入力され
る値。
例)run("Analyze Particles...", "size=0-Infinity
circularity=0.00-1.00 show=Nothing display exclude clear
summarize add stack");
これはAnalyze>Analyze
Particlesを右の設定で実行し、
"Process all images ?"の質問に
Noと答えた場合の操作を実
行する。Yesと答えるとstack
(スタック全体)、Noと答
えるとslice(スライス一枚)
というオプションになる。
45
run関数など(2)
例)run("Set Scale...", "distance=&scale known=1 pixel=1
unit=&unit");
このように&を使うと変数の値を用いることができる。
(scale, unitが変数であり、あらかじめ値が代入されて
いる。)
doCommands(): メニューコマンドを実行するが、開始
したらそれと独立(同時)にマクロの実行が進む。
 exit(), exit("error message"): (エラーメッセージを出し
て)マクロを終了する。

46
スタック関係の関数
nSlices: スライスの総数
 getSliceNumber: 現在表示されているスライス
の番号を返す。1からnSlicesの間の値。
 setSlice(n): アクティブなスタックのn番目のス
ライスを表示する。

47
測定関係の関数





setThreshold(lower, upper): Thresholdの下限値と上限値
を設定する。3番目の引数として、
"red""black&white""over/under""no color"等を指定する
こともできる。
setAutoThreshold(): アクティブな画像や選択枠に対し
てオートでThresholdを設定する。オプションとして
オートの計算方法を()内に指定できる。
resetThreshold(): Threshold機能を無効にする。
getThreshold(lower, upper): 設定されているThresholdの
下限値と上限値をlower, upperに返す。設定がされて
いなければ-1を返す。
nResults: Resultテーブルのデータ数(総行数)を返す
。
48
測定関係の関数




getHistogram(values, counts, nBins[, histMin, histMax]): 現在の画像や選
択枠のヒストグラムを返す。 valuesとして各binの下端値の配列を
与える。設定不要のとき(binが1のときなど)は0にする。counts
はヒストグラムカウントの値の配列が返される。nBinは使うBinの
数。8 bit画像とRGB画像では256でなくてはいけない。
getStatistics(area, mean, min, max, std, histogram): ()内に設定した変数
にアクティブな画像または選択枠の面積、ピクセル値の平均、最
低、最高、標準偏差、およびヒストグラムを返す。ヒストグラム
は256個の要素をもつ配列が返される。引数は順番通りに書かない
といけないが、後ろの方の引数は省略してよい。例えば
getStatistics(area, mean)。
getRawStatistics(nPixels, mean, min, max, std, histogram): getStatisticsと
同様だが、キャリブレートしてない値を返す。またhistogramは
max+1要素の配列として返される。
getResult("Column", row): Resultsテーブルから値をとる。"Column"
は"Area","Mean","Circ"などResultsテーブルの列のタイトル。rowは
行の番号で、0<=row<nResults。省略すると最後の行の値を返す。
49
算術関数
sqrt(n): 平方根
 abs(n): 絶対値
 round(n): nに最も近い整数を返す。
 floor(n): 切り捨てて整数にする。
 maxOf(n1, n2): 二つの数のうち大きい方を返す。
 minOf(n1, n2): 二つの数のうち小さい方を返す。
 pow(base, exponent): 累乗。つまりbaseのexponent乗。
 exp(n): en
 log(n): 自然対数。log10(n)=log(n)/log(10).
 random: 0と1の間の乱数を返す。

50
算術関数








isNaN(): nの値がNaN (Not-a-Number)であればTrue(1)を
返す。例えば0を0で割るとNaNになる。
cos(angle): angle(ラジアン)のコサイン
sin(angle): angle(ラジアン)のサイン
tan(angle): angle(ラジアン)のタンジェント (ラジアン)。 π/2 とπ/2の間の値になる。
acos(n): アークコサイン (ラジアン)
asin(n):アークサイン (ラジアン)
atan(n):アークタンジェント (ラジアン)。 -π/2 とπ/2の間
の値になる。
atan2(y, x): y/xのアークタンジェントを-π~πの間の値で
返す。
51
文字列操作関数
lengthOf(str): 文字列(または配列)の長さ
 startsWith(string, prefix): stringがprefixで始まればTrue(1)
を返す。
 endsWith(string, suffix): stringがsuffixで終わればTrue(1)を
返す。
 indexOf(string, substring[, fromIndex]): stringの中で
fromIndexの位置以降、最初にsubstringが出てくる位置
を返す。fromIndexを指定しないと先頭(左端)から探
す。
 lastIndexOf(string, substring): stringの中で最も最後(右
)にsubstringが出てくる位置を返す。
 toLowerCase(string): すべて小文字になおす。
 toUpperCase(string): すべて大文字になおす。
52

文字列操作関数



replace(string, old, new): stringの中に出てくる一文字の
文字oldをすべて一文字のnewに置き換える。(Java1.4
以降の上で走っている場合はold, newは正規表現でも
いい。)
substring(string1, index1, index2): stringのindex1番目の文
字からはじまりindex2-1番目の文字までの部分文字列
を返す。
split(string[, delimiters]): stringをdelimiterで区切り、部分
文字列の配列を返す。elimiterは1文字あるいは複数文
字からなる。delimiterを指定しない、あるいは空白文
字を指定した場合はデフォールトの区切り文字をスペ
ース、タブ、CR、Lfのすべてとする。stringの中に区
切り文字が見つからない場合は要素1個の配列が返さ
れる。
53
文字と数字の変換








d2n(n, decimalPlaces): 小数点以下の桁数をdecimalPlaces桁として数
字nを文字に変換する。
fromCharCode(value1,...,valueN): 一個以上の文字コード(Unicode
)の値を文字列にする。
parseFloat(string): 文字列を数字になおす。数字に直せない場合は
NaN(not a number)を返す。
parseInt(string):文字列を整数になおす。整数に直せない場合は
NaN(not a number)を返す。
parseInt(string, radix): 文字列をradix進数と解釈して整数に直す。
例えばradixを16にすると0,1,,,9,A,,,F(小文字でもよい)よりなる16
進数を数値に直す。
toString(number): 数字を文字列にする。
toBinary(number): 数字を2進数の文字列にする。
toHex(number): 数字を16進数の文字列にする。
54
シンプルなユーザーインターフェース

showMessage(["title", ]"message") : "message"を書いたダイアログボックスを
表示する。指定されていればボックスのタイトルが"title"となる。

showMessageWithCancel(["title",]"message"): "OK"と"Cancel"ボタンを持ち
"message"を書いたダイアログボックスを表示する。 Cancelボタンが押さ
れるとマクロが終了する。

getBoolean("message"): "message"と"Yes","No","Cancel"ボタンを書いたダイア
ログボックスを表示し、Yesをクリックした場合True(1)を、Noをクリック
した場合False(0)を返し、Cancelをクリックした場合はマクロを終了する。

getNumber("prompt", defaultValue): ダイアログボックスを表示し、ユーザー
が"prompt"と表示されたボックス入力した数字を返す。defaultValueが最初
にボックス内に表示される。無効な入力をした場合はdefaultValue が返さ
れる。Cancelをクリックした場合はマクロを終了する。

getString("prompt", "default"):ダイアログボックスを表示し、ユーザーが
"prompt"と表示されたボックス入力した文字列を返す。defaultが最初にボ
ックス内に表示される。無効な入力をした場合はdefaultが返される。
Cancelをクリックした場合はマクロを終了する。
55
ダイアログボックス









ユーザーからの入力を受け取るボックスを一枚のウィンドウに並
べて表示する。
Dialog.create("Title"): "Title"のタイトルのダイアログボックスを作成
。
Dialog.addString("Label","Initial text"): テキスト入力ボックスを追加。
Dialog.addNumber("",""): 数字入力ボックスを追加。
Dialog.show(): ダイアログボックスを表示する。
Dialog.getString(): ユーザーが入力したテキストを取得。
Dialog.getNumber(): ユーザーが入力した数字を取得。
他にチェックボックス、ポップアップメニューでの選択肢などを
表示できる。Macroマニュアルの規定関数参照。
使い方は、create→ボックスを順にadd→show→値を順番にget。ボ
ックスを追加した順番と取得する順番を揃える必要がある。
56
ダイアログボックスの作成例
(DialogDemoより)
title = "Untitled";
width=512; height=512;
Dialog.create("New Image");
Dialog.addString("Title:", title);
Dialog.addChoice("Type:", newArray("8-bit", "16-bit", "32-bit",
"RGB"));
Dialog.addNumber("Width:", 512);
Dialog.addNumber("Height:", 512);
Dialog.addCheckbox("Ramp", true);
Dialog.show();
title = Dialog.getString();
width = Dialog.getNumber();
height = Dialog.getNumber();;
type = Dialog.getChoice();
ramp = Dialog.getCheckbox();
if (ramp==true) type = type + " ramp";
newImage(title, type, width, height, 1);
57
ファイルを開く/保存する(1)



open(path): tiff, dicom, fits, pgm, jpeg, bmp, gif, lut, roi, textファイルのいず
れかを開く。これらのフォーマットでない場合やファイルがみつ
からない場合はエラーメッセージを表示してマクロを終了する。
pathを書かないかpathが空の文字列であればfile openダイアログボ
ックスを開く。
save(path): 画像、LUT、選択枠、テキストウィンドウを指定された
pathの場所に保存する。pathは".tif", ".jpg", ".gif", ".zip", ".raw", ".avi",
".bmp", ".fits", ".png", ".pgm", ".lut", ".roi", ".txt"のいずれかで終わらなけ
ればならない。
saveAs(format, path): アクティブな画像、LUT、選択枠、測定結果、
選択枠のXT座標、テキストウィンドウを指定されたpathの場所に
保存する。formatは"tiff", "jpeg", "gif", "zip", "raw", "avi", "bmp", "fits",
"png", "pgm", "text image", "lut", "selection", "measurements", "xy
Coordinates" or "text"のいずれかでなければならない。
saveAs(format) とすると"Save As" ダイアログが表示される。
58
ファイルを開く/保存する(2)


File.open(path): 出力用に新たなファイルを作成し、それを参照する
変数(ファイルハンドル)を返す。pathが空の文字列であればfile
saveダイアログが表示される。マクロが終了するときにはファイル
が閉じられる。
print(string): stringをlogウィンドウに出力する。数字は自動的に文字
に変換される。 print(x+" "+y+" "+width+" "+height) のかわりに
print(x,y,width, height)と書くことができる。
print(fileHandle, string)としてFile.open(path)で返されたファイルハン
ドルを渡すとstringがファイルに出力される。stringを
"\\Clear"とするとlogウィンドウをクリアする。
59
ウィンドウ/画像関係の関数





newImage(title, type, width, height, depth): 画像やスタックを新た
に作成する。typeは"8-bit","16-bit","32-bit","RGB"のいずれかを
含むこと。また、"white","black","ramp"(勾配)"を含んでもい
い(書かないとwhiteになる)。例えば"16-bit ramp"とすると
グレースケールの勾配の画像になる。width(画像の横サイズ
), height(画像の縦サイズ)はピクセル数。depthはスライス
数。
selectWindow("name"): "name"の名前のウィンドウをアクティ
ブにする。
rename(name): アクティブな画像の名前をnameにかえる。
nImages: 開いている画像の数を返す。
close(): アクティブな画像を閉じる
60
ウィンドウ/画像関係の関数








getTitle(): アクティブな画像のタイトルを取得する。
getImageID(): アクティブ画像のID番号(負の整数)を取得する。
getWidth(): アクティブな画像の横幅(ピクセル数)を取得する。
getHeight(): アクティブな画像の縦の長さ(ピクセル数)を取得す
る。
bitDepth(): アクティブな画像のピクセル値のビット数を返す。8, 16,
24(RGB), 32(float)のいずれかが返る。
selectImage(id): idのID(負の値)を持つ画像をアクティブにする。
idが正の値の場合、Windowメニューに示された順でid番目の画像
をアクティブにする。
snapshot():アクティブな画像のバックアップコピーをとる。あとで
resetにより回復できる。
reset(): バックアップ画像を回復する。
61
選択枠関係の関数






makeLine(x1, y1, x2, y2): 直線選択枠を作成する。座標のセットを
並べることで複数の直線を選択することもできる。例えば
makeLine(25,34,44,19,69,30,71,56)。
makeOval(x, y, width, height): 楕円の選択枠を作成する。
makePolygon(x1, y1, x2, y2, x3, y3, ...): 多角形の選択枠を作成する。
少なくとも3つ、200を超えない数の座標を指定する。例)
MakePolygon(20,48,59,13,101,40,75,77,38,70)により五角形の選択
枠ができる。
makeRectangle(x, y, width, height): 長方形の選択枠を作成する。
makeSelection(type, xcoord, ycoord): xcoord and ycoordはそれぞれ
X座標、Y座標を表す数値配列。typeは"polygon", "freehand",
"polyline", "freeline", "angle", "point"のいずれか、あるいは
selectionTypeで返される数値。
getSelectionCoordinates(sCoordinates, yCoordinates): 現在の選択
枠を規定する点群のX座標、Y座標を2つの配列として返す。
62
描画関係の関数








setColor(r, g, b): 描画をする際の色を設定。r, g, b は0以上255以下
の整数。
setColor(value):描画をする際の色を設定。 8ビット画像では
0<=value<=255. 16ビット画像では0<=value<=65535. RGB画像では
16進定数を用いて表現。例えば赤は0xff0000。
上記ふたつはForeground Colorの設定は変えない。従って
run("Draw")やrun("Fill")の際の色には影響しない。
setForegroundColor(r, g, b): Foreground colorを設定する。 r, g, b は0
以上255以下の整数。
setBackgroundColor(r, g, b): Background colorを設定する。 r, g, b は0
以上255以下の整数。
setLineWidth(width): 描画の線の太さを設定する。
setFont(name, size[, style]):nameは"SansSerif", "Serif", "Monospaced"の
いずれか。styleとして"bold","italic",または両方を指定することが
できる。さらに"antialiased"を指定するとスムージングされた文
字となる。
setJustification("center"): 文字列の配置として"left","right","center"の
63
いずれかを指定する。
描画関係の関数









drawLine(x1, y1, x2, y2): (x1, y1)と(x2, y2)の間に直線を引く。
drawRect(x, y, width, height): 左上角の座標が(x,y)で幅と高さが
width, heightの長方形の輪郭を描く。
drawOval(x, y, width, height): 外接する長方形が(x,y,width,height)
で規定される楕円の輪郭を描く。
drawString("text", x, y): (x,y)の位置に文字列を書く。
fill(): Selectionの中を塗りつぶす。
fillRect(x, y, width, height):左上角の座標が(x,y)で幅と高さが
width, height塗りつぶされた長方形を描く。
fillOval(x, y, width, height):外接する長方形が(x,y,width,height)で規
定される塗りつぶされた楕円を描く。
これらの操作の際の色や線の太さ、フォント等は次の関数群
を用いてあらかじめ設定しておく。
updataDisplay(): アクティブな画面の内容を更新する。
64
描画関係の関数-位置関係
drawOval(x, y, w, h);
drawRect(x, y, w, h);
Foreground
color
(x, y)
h
fillRect(x, y, w, h);
(x, y)
h
w
Background
color
drawString("TEXT", x, y);
TEXT
(x, y)
w
setJustification("right");
drawString("TEXT", x, y);
TEXT
(x, y)
65
その他の関数
Plot.xxxx(): グラフを書く関数群
 roiManager(): ROIマネジャー関係の関数
 File.xxxx(): ファイル操作関係

以上については"ImageJ - Built-in Macro
Fuctions"を参照。
 他にもここに記載しなかった関数が多くあ
る(特にgetXxxx)。省略した説明もあるの
で必要に応じマニュアルを参照すること。

66
その他の情報
67
ImageJのインストール

自分のPCにImageJをインストールする場合は以
下のページの手順に従ってください。
http://wiki.livedoor.jp/imagej/

ImageJが立ち上がるかどうか、確認してくださ
い。

大きな画像やムービーを扱う際に、メモリが足
りなくなることがあります。変更が必要な場合、
上記ページにも説明がありますが、ImageJを立
ち上げたあと、Edit>Options>Memory and
Threadsで最大メモリサイズを変更してください。
設定後再度ImageJを立ち上げたときに設定が有
効になります。
68
QuickTimeへの対応

Mac版ImageJはデフォールトでQuickTimeに対応して
いる。

Windows版のImageJでQuickTimeファイルを読めるよ
うにするには以下のようにインストールする。
1) QuickTimeをインストール
( http://www.apple.com/jp/quicktime/download/ )。
2) QuickTimeのプログラムフォルダ(例えば
C:\Program Files\QuickTime)のQTSystemフォルダ内
のQTJava.zipファイル(フォルダの形のアイコン)を
ImageJプログラムフォルダのImageJ\jre\lib\extにコピー
する。
<注意>Windowsでは対象のQuickTime画像を含む
フォルダ(またはさらに上位のフォルダ)名に日本
語が含まれるとエラーになる場合があります。
69
他の画像形式への対応

"Bio-Formats"プラグインを用いると、メタモル
フのstkファイルやLeicaのlifファイルなど、多
くの画像ファイル形式を読み込めるようにな
るので以下の手順でインストールしておくと
よい。
1)http://www.loci.wisc.edu/software/bio-formatsに
アクセス。
2)下の方の"download"の"Bio-formats
Downloads"をクリックし、
bioformats_packages.jarを右クリック→「名前
をつけてリンク先を保存」でImageJプログラム
フォルダのpluginsフォルダにダウンロード。
3)ImageJを立ち上げなおす。
70
他の画像ソフト
Fiji (Fiji is Just ImageJ) http://fiji.sc/Fiji
はImageJにさまざまな機能がプラグインとして
付加されたものであり便利。使い勝手はImageJ
と全く同じなので、最初からImageJでなくFijiを
インストールして使っている人も多い。
 NI Vision, Image-Pro, Metamorphなど顕微鏡用ま
たは単独で用いる有料画像解析ソフトがいろ
いろある。いずれかを研究室で所有している
ことが多い。
ーこれらのソフトにはたいていマクロ機能が
あるので、実験で使うプロトコールでの画像
取り込みなど、自動化を試みてほしい。それ
ぞれのマニュアルを見てください。
71

ダウンロード

statement(s)