WaveFormer Pro 操作ガイド
1
InterLink
目次
基本時間単位(BaseTimeUnit)の設定
ー4項
表示時間単位の(DisplayTimeUnit) 設定
ー5項
各ウィンドウの概観
ー6項
クロック信号の定義の仕方
ー8項
信号の追加/描画/編集
ー9項
遅延と制約のあたえ方
ー23項
ライブラリについて
ー30項
Boolean 式/シュミレーションによる波形生成
ー36項
「時間式による波形生成」と「自動ラベル機能」 ー40項
バスについて
ー41項
グリッドライン/タイムコンプレスマーカーの記述ー44項
プリントについて
ー47項
インポート/エクスポート機能
ー50項
波形比較
ー58項
アナログ波形について
ー62項
2
InterLink
波形のサンプル
プログラムインストールフォルダ内の Examples ディレクトリの
中には、色々な波形例がございます。
0ns
50ns
100ns
150ns
200ns
2
350ns
400ns
257.024Features
Realistic Data Book Documentation
450ns
457.04
Realistic Data Book Documentation Features
t ime-break has c ompres ed t ime 50ns
SI G0
t pd
B oldnames
SI G1
1) Ric h Edit support f or paramet er names , tex t objec ts , and c omments
Up There
SuperSc ripts CR TL-U (up) ex: hello
Subs cript s C TR L- D (down) ex : hello
Down There
Bold CR TL-B ex:B ig and Bo ld
I talic CR TL-I exAmazing
:
Make me Bold SuperScript Subscript Italic
3) Text and Edge Grids
C hoos e t he menu it em
Opti ons - Grid Setti ngs
Ex periment with dif f erent s et tings
D rag-n-D rop text objec ts and s ignal edges
N ot ice how t hey mov e wit h dif f erent sett ings
Make me Bold SuperScript Subscript Italic
C LK0
s elec t cloc k se gme nt
3
InterLink
500ns
基本時間単位(BaseTimeUnit)の設定
メニュー[Options]>[Base Time Unit]を選択すると基本時間単位を
設定するラジオボタンを含んだダイアログボックスが開きます。
画面上ではnsのラジオボタンを選択しているので
最小分解能が1[ns]になります。
他のオプションは現在のパラメーターや信号が、
基本時間変更によりどのように影響を受けるかを
制御するためのものです。
4
InterLink
表示時間単位の(DisplayTimeUnit) 設定
メニュー[Option]>[Display Unit]を選択する
と表示時間を設定するサブメニューが現れるので
設定します。
表示時間単位は入力された時間およびWaveFormer
Proが表示する時間の単位です。
表示時間は、整数部.小数部共に桁が多くならない対
象の設計に適切な値を設定するとよいでしょう。
5
InterLink
各ウィンドウの概観
波形ウィンドウ
パラメータ・
ウィンドウ
レポート・
ウィンドウ
6
InterLink
各種ボタンについて
新たな信号の追
加ボタン
ステートの状況を
表すボタン
ズーム
ボタン
モードボタン
ご参照:スケーリング操作
http://www.syncad.com/ani_app.htm
(アニメーション・アプリケーション)
7
InterLink
クロック信号の定義の仕方
・[Add Clock]ボタンをクリックするとクロックがデフォルト名で
追加されEdit Clock Parameters ダイアログが開きます。
①
②
① ラベルセクション:
クロック名の入力
③
② クロックレートセクション:
クロックの速度の入力(周波数、または周期)
式によるクロック信号の定義
例) 2*CLK0.period:
信号名CLK0の2倍のクロック周期のクロックを生成する。
③ クロックプロパティセクション:
スタートオフセット、デューティーサイクル等の変更
8
InterLink
信号の追加
[Add signal]ボタンを
左クリックすると(ここでは二回クリックしています。)
信号SIG0とSIG1(デフォルト名)が追加されました。
(二回クリックしているので二つの信号が追加され
ています。)
9
InterLink
信号の編集
Signal properties ダイアログ
・信号名をダブルクリックするとSignal Propertiesダイアログが開き
ます。このダイアログ内で様々な信号の編集、生成を行います。
①
① ネームセクション
②
② ロジックウィザードセクション
③
③ 時間式のセクション
④
④ エクスポートセクション
10
InterLink
信号波形の描画1
始めに希望のステートボタンの上で左クリックし描きたいステイトを選択します。
ステートボタンはここでは[High]になっています。(赤文字)
マウスカーソルを信号名と
同じ高さに置き左クリックします。
[High]の波形がマウスカーソルの
位置まで描かれました
(ステートボタンが[Low]に
変わっています。次項説明)
11
InterLink
信号波形の描画2
ステイトは直前に選択されたものと赤字になっている現在選択中の二つの間を
波形セグメントの描画の度に自動的にトグルします。
次に選択されるステートにはそのボタン上に
赤いTマークがつきます。(ここでは、Highに印がついています。)
画面では次に描かれるステートは
[Low]以後、high>low>high>lowと切り替わります。
なお、トグルさせたくない場合は左のようには赤文字になっている
現在選択中のステイトボタンを左クリックして、現在選択中のステート
ボタン上に赤いTマークつけます。
12
InterLink
信号波形の編集1
・信号値変化点の移動
変化点で左クリックすると緑のバーが現れます。
このバーを希望の位置までドラッグします。
変化点が移動しました。
13
InterLink
信号波形の編集2
・波形セグメントの種類の変更
波形セグメントとは隣り合う二つの信号変化点間の波形のことです。
この属性を変更するにはまず編集したい波形セグメント内で左クリックし選択します。
選択された波形セグメントは
四角の枠で囲まれます。
ズームインボタン
波形セグメントを選択したら希望するステートボタンクリックします。
セグメントの属性が
変更されました。
もし幅の狭い波形セグメントを選択する場合、波形の変化点が選択されてしまうことがあります。
このような時はダイアグラム・ウィンドウ右上部にあるズームインボタンを
クリックして拡大表示すれば選択しやすくなります。
14
InterLink
信号波形の編集3
・波形セグメントの削除
セグメントを選択した後Deleteキーを押せば削除できます。
セグメントが削除されました。
信号自体を削除する場合は波形の名前を左クリックで選択し
(信号名が反転表示になります。)Deleteキーを押します。
15
InterLink
信号波形の編集4
・波形セグメントの挿入
赤い枠で囲んだセグメント内に挿入します。
挿入したい位置で左クリックすると緑のバーが現れるので
左右どちらかにドラックします。
希望長さの位置でマウスを離すとセグメントが挿入されます。
セグメント幅の編集や波形の属性変更をし希望の波形にします。
16
InterLink
信号波形の編集5
・複数の信号変化点の移動
(1) <1>キー<2>キーを使った移動
<1>キーを押したまま信号変化点を選択しドラッグすることによって、
選択した信号変化点とその信号変化点からの左のすべての信号変化点が同時に移動します。
<1>キーを押しながら
ドラッグします
変化点が移動しました。(この画面では左にドラッグしました。)
<2>キー押しながら変化点選択しドラッグすると、
選択した信号変化点とその信号変化点から右のすべての信号変化点が同時に移動します。
<1>キーと<2>キーを同時に押しながらドラッグすると、
すべての信号変化点が同時に移動します。
17
InterLink
信号波形の編集6
・複数の信号変化点の移動(続き)
(2)<Ctrl>キーを使った移動
<Ctrl>キーを押しながら左クリックで複数の変化点を選択しドラッグすることによって、
選択した変化点(だけ)を同時に移動することができる。
<Ctrl>キーを押しながら
複数の信号変化点を
選択します。
いずれかの信号変化点を
ドラッグします。
選択した信号変化点が移動しました。(この画面では左にドラッグしました。)
18
InterLink
信号波形の編集7
・信号波形のコピー
(1)すべての信号波形をコピーする
SIG0を別の信号にコピーします。
SIN0を選択します。(信号名が反転表示になる。)
メニュー[Edit]>Copy Signalsを選択し、
次にメニュー[Edit]>Paste Signalsを選択します。
信号がコピーされました。
(信号名をダブルクリックしてシグナルプロパティ・ダイアログボッックスを
開き希望の信号名に変更します。)
19
InterLink
信号波形の編集8
・信号波形のコピー(続き)
(2)信号波形の部分的なコピー
SIG0の波形の50nsから150nsまでを
SIG1の70ns以降にコピー(挿入)します。
SIG0を選択しメニュー[Edit]>[Block Copy Waveform]を
選び、Block Copy Wave ダイアログを開きます。
挿入の場合はInsert、上書きの場合はOverwriteの
ラジオボタンにチェックを入れます。
各数値を入力し、Change Waveform Destinationの
プルダウン・メニューよりSIG1を選択し[OK]を押す。
ダイアログに入力する値は
Start : 50
End : 150
Place at : 70
信号波形が部分的コピー(挿入)されました。
20
InterLink
信号波形の編集9
・式による波形変化点の編集
編集したい信号名を選択しメニュー>[Edit]>
[Edit Wave form Edges….]を選択しダイアログを開きます。
Transform Edge Time in Rage:のラジオボタンに
チェックがしてあること確認します。
Edge Time Equation:のプルダウンボックスに
任意の式を入力し[OK]または[Apply]をクリックします。
元信号波形
$time + 100をボックスに入力した波形
$time *2をボックスに入力した波形
21
InterLink
信号の移動と再構成
・単一の信号移動
信号SIG1を信号SIG0の上に移動します。
SIG1を左クリックで選択(反転表示)します。マウスカーソルをSIG1の上部近辺に置き
カーソルの形状が通常の矢印からアップダウン矢印にかわったら、左クリックします。
すると緑色のバーが表示されます。
緑色のバーが信号CLK0SIG0の間に移動するようにドラッグし離します。
信号の位置が
移動しました。
・複数の信号を移動
複数の信号名を左クリックで選択(反転表示)し上記と同じ方法で移動します。
なお複数の信号を移動する場合の移動後の信号の位置は、信号を選択する順序によります。
この方法で多くの要素からなる信号群をすばやく再構成することができます。
22
InterLink
遅延と制約のあたえ方
-Delay、Setup、Holdパラメータによるタイミ
ング解析例-
[Setup]、[Hold]タイミング・
パラメータを使用すると、タ
イミング違反が発生した場合
、ダイアグラムとパラメータ
ウィンドウでレポート
(右図例では、セットアップ
エラーをレポート)
0ns
20ns
40ns
60ns
80ns
100ns
120ns
140ns
End Diagram
c lk
I NVt p
Setup
H old
D input
D FFtp
使用回路
Qoutput
name
min
D FFtp
max
margin
c omment
18
na (delay )
c lk to Qoutput propagation tim e
11
na (delay )
INV inv erter delay
C heck f or metastable c ondition
INVtp
3
Setup
25
-4
H old
1
28
23
InterLink
遅延と制約のあたえ方1
・遅延(delay)のあたえ方
モードボタンの中から左クリックでdelayを
選択します。選択したボタンは赤表示になります。
CLK0の最初の立ち上がり変化点(エッジ)で左クリック、
Qoutputの最初の立ち下り変化点で右クリックすると….
遅延パラメーターがデフォルト名D0で追加されます。
遅延パラメーターが新規追加時点では、それは空のままで遅延が発生することはありません。
24
InterLink
遅延と制約のあたえ方2
・遅延(delay)のあたえ方(続き)
パラメーターウィンドウ内のパラメーターをダブルクリックすると
Parameter Propertiesダイアログが開きます。
nameの項にDFFtp,minの項に5と入力すると….
入力した名前に変更され、Qoutputの立ち下り変化点幅が
CLKエッジから見て5[ns]に変更されました。
また、遅延パラメーターが灰色から青字表示に変わります。
これは信号の最小変化点幅のみに影響をあたえるということ
を表しています。
25
InterLink
遅延と制約のあたえ方3
・制約(set up)のあたえ方
下のタイミングダイアグラムは前頁のダイアグラムにQoutputの最初の立ち下がり変化点で
左クリック、Dinputの最初の立ち上がり変化点で右クリックして遅延パラメーターINVtpを加えたものです。
パラメーター内の数値は右の図のとうりです。
このダイアグラムにDinput→CLK0の制約(set up)あたえます。Set upの
モードボタンを有効してDinputの最初の立ち上がり変化点で左クリック、
CLK0の二番目の立ち上がり変化点で右クリックすると….
Set upパラメーターがデフォルト名S0で
追加されます。
26
InterLink
遅延と制約のあたえ方4
・制約(set up)のあたえ方(続き)
set upもdelayと同様にパラメーターをダブルクリックし
ダイアログ開き値を入力することができます。
nameにDsetup
min値に15を入力しました。
リードアウトに-21[ns]と表示されています、これはCLK0の二番目立ち
の上がり変化点からDinputの不確定領域の終了点を計測したものです。
set up時間15[ns]-計測された時間-21[ns]=-6
となるので余裕時間は6[ns]となります。
27
InterLink
遅延と制約のあたえ方5
・制約(Set up)のあたえ方(続き)
遅延パラメーターINVtpのmaxの値を11nsから18nsに増やしてみます。
すると、タイミングダイアグラム、パラメーターウィンドウの両方でSet up パラメーターが
赤字で表示されます。これはSet up の時間が保持されていないことを表しています。
28
InterLink
遅延と制約のあたえ方6
・フリーパラメーターの追加
パラメーターウィンドウ上の[Add Free Parameter]ボタンクリックするとパラメーター内に
空のフリーパラメーターが追加されます。他のパラメーター同様に値を入力します。
nameにtpFreelnv
minに3[ns]、maxに11[ns]を
入力しました。
INVtpのminとmaxの項にtpFreelnvと入力すし[Apply]をクリックすると
INVtpの最小/最大値がフリーパラメーターtpFreelnvの最小/最大値に制御されます。
29
InterLink
ライブラリ
Wave Former Proにはライブラリを参照して、
パラメーター値を入力する機能があります。
30
InterLink
ライブラリ1
・検索リストにライブラリを追加する
メニュー>[Parameter Libs]> [Parameter Library Preferences]クリックすると
ダイアログを開きます。[Add to library]ボタンをクリックすると[Library Browse]
ダイアログが開くので任意のライブラリファイルを選択します。
ダイアログ内のライブラリリストのパスに
選択したライブラリが登録されました。
ライブラリを選択して右矢印ボタンをクリックし
ライブラリ特性を定義します。
31
InterLink
ライブラリ2
・ライブラリ内のパラメーターを参照する
次のタイミングダイアグラム(SynaptiCAD\Examples\TutorialFiles\ParameterLibraries内の
tutlib.btim )のパラメーターをライブラリを使って編集してみます。
Dsetupパラメーターのmin値をダブルクリックし、Parameter propertiesダイアログ開きます。
min値を削除しF3キーまたはダイアログ内下部のlibraryボタンをクリックし
[View Parameter in Library]ダイアログを開きます。
32
InterLink
ライブラリ3
・ライブラリ内のパラメーターを参照する(続き)
ライブラリ一覧からリストに追加したac.txtを選択すると、このライブラリにある
パラメーターが一覧内に表示されます。スクロールバーを操作して任意のパラメーター
(ここでは074;D2CK_ts)を選択し[OK]をクリックします。
すると、Parameter propertiesダイアログに
選択したパラメーター名が入力されています。
また、ライブラリ特性“ac”がパラメーター名の前にコロンで区切られてつけられます。
33
InterLink
ライブラリ4
・マクロによるライブラリ間でのトレードオフの検証
注)引き続き前項までと同じタイミングダイアログを編集しています、なおDFFtpは+ac:074;CK2Q_tpを
INVtpには+ac:004;tを、それぞれライブラリから参照しmin.max項ともに追加しています。したがって
DFFtp,INVtp,Dsetupのすべてが“ac”から参照していることになります。
メニュー>[Parameter Libs]>[Macro Substitution List]を
選択してEdit Formula Macro ダイアログ開きます。
Nameの項に %ac%(これがマクロ)と入力し、
Valueの項に ac と入力します。 [OK]ボタンを
クリックしマクロリストにこのマクロを追加します。
マクロリスト
次にDFFtp,INVtp,Dsetupのmin値とmax値の
パラメーターの+ac部分を%ac%に置き換えるように編集します。
34
InterLink
ライブラリ5
・マクロによるライブラリ間でのトレードオフの検証(続き)
メニュー>[Parameter Libs]>[Macro Substitution List]を
選択してEdit Formula Macro ダイアログ開きます。
マクロリスト内のマクロ%ac%をクリックすると、このマクロの定義がName と Value の
項目に表示されます。 (この場合、マクロ%ac%にはacが割りあてられています。)
Value の項目を3acに変更して[Add]ボタンをクリックして3ac に更新します。
すると、全パラメーターが3[v]用(3ac)のライブラリに従います。
(電源電圧が低下したため遅延時間が長くなっています。)
35
InterLink
BooleanやVerilogでの
信号生成(WFP以上)
reg [3:0] COUNTER;
always @(posedge CLK)
begin
if (RST)
COUNTER = 4’b0000;
else
COUNTER = COUNTER + 1; // count
end
assign CLK_count = COUNTER;
36
InterLink
Boolean 式からの波形生成
下図のダイアグラムの信号SIG2を論理式で生成します。
SIG2のSignal Properties ダイアログ開きます。
Boolean Equationのラジオボタンがチェックしてあること確認し
Boolean Equation の項に以下の論理式を入力します。
(SIG0 and SIG1) delay F0
[Simulate Once] ボタンをクリックすると….
信号SIG2自身の波形が描かれます。
(論理式(SIG0 and SIG1) delay F0結果)
delay演算子はパラメーター名や時間値を
オペランドとしてとることができます。
37
InterLink
シュミレーションによる波形生成
論理式を入力しSimulate Onceボタンをクリックすると
シュミレーションが一度行われるますが、Simulateラジオボタンに
チェックを入れることによりひとつの作業をする度にシュミレー
ションを自動更新させることができます。
SIG0の変化点の一つを右に移動すると
SIG2も自動更新されます。
*Simulateラジオボックスにチェックをいれ
ると信号名と波形が紫色になります。
38
InterLink
レジスタとラッチ信号モデル
・ラッチ、レジスタの生成
論理式を使ってモデリングされた回路例
SIG0を立ち下がりクロック信号とした場合のシュミレーション
SIG2のBoolean Equation の項にSIG1と入力します。
ClockプルダウンボックスからSIG0を、Edge/Level
プルダウンボックスからnegを選択すると…..
下図のようにシュミレートされます。
SIG2がSIG0の立下りエッジに同期して変化してします。
39
InterLink
「時間式による波形生成」と
「自動ラベル機能」
時間式による波形生成([Wfm Eqn]ボタン)と
自動ラベル機能([Label Eqn]ボタン)で生成した波形の例
0ns
50ns
100ns
150ns
200ns
250ns
300ns
W fm Eqn:(20ns=0 20ns=1)*4 (10ns=0 10ns=1)*5
SIG0
W fm Eqn:8ns=Z (5=1 5=0)*5 9=H 9=L 5=V 5=X
SIG1
W fm Eqn:(20 = V) * 10
Label Eqn :Hex(Inc(0,2,10))
SIG2
0
2
4
6
8
a
c
e
10 12
W fm Eqn:(20 = V) * 10
Label Eqn :Hex(RandInt(10,255))
SIG3
bf 9a 21 1c 7e e5 ea f c 6b a5
40
InterLink
バスについて1
・仮想バスの生成
バスの種類を表すVALボタンを二回クリックしてアクティブに固定します。(トグルしないように)
波形を描くと下図のようなVALタイプの波形が描画できます。(図では四つのセグメントを描画しました。)
セグメントを選択しHEXボタンを押す、またはセグメントを
ダブルクリックすることによって[Edit Bus State]を開くことでき
Bus 内のデータを入力することができます。
仮想バスがVHDLやVerilog-HDLに変換されるとき、仮想ステート
情報がグラフィカルな状態にとって代わります。これによりグラフィカルに
表現できない型(integerなど)付きの信号の変更ができます。
41
Next,Prev ボタンまたはAlt+N,
Alt+Pボタンを使うと次、前の
セグメントに移動することが
できます。
InterLink
バスについて2
・グループバスの生成
他の信号が選択されていないことを確認し
[Add Bus]ボタンをクリックしダイアログを開きます。
Start,Endの値(ここでは0と1)を入力しGroup Busのラジオ
ボタンにチェックをいれ[OK]をクリックします。
Start:(LSB#)はバス最小位ビットを表し
End:(MSB)はバスの最上位を表します。
BUS0[1:0]とバスを構成する要素信号BUS_0とBUS_1が生成されます。
バス信号BUS0[1:0]にhigh,low波形を描くと要素信号は
バス信号BUS0[1:0]に設定された値にしたがって自動的に描かれます。
さらにBUS[1:0]のステートデータ[3,0,3,0,3]を[Edit Bus State]を開き
変更すると要素信号も自動的に更新されます。
42
InterLink
バスについて3
・シュミレーティッドバスの生成
シュミレーティッドバスはグループバスと似ているものですが、大きな違いとして挙げられるのは
シュミレーティッドバスはブール方程式で生成される点です。シュミレーティッドバスは他の信号の
ブール方程式を参照して生成することができます。(グループバスは不可)
[Add Bus]ボタンをクリックしダイアログを開きStart,Endの値(ここでは0と2)を
入力しsimulated Busのラジオボタンのチェックをいれ[OK]をクリックします。
BUS0[2:0]と三つの要素信号が生成されます。
BUS0[2:0]をダブルクリックしSignal properties ダイアログ開き
Boolean Equationの項を見ると要素信号が連結しているのが
わかります。
要素信号に波形を描くとBUS[2:0]が自動的に描かれます。
(シュミレートされます。)
43
InterLink
グリッドラインの記述1
・CLK0の信号変化点にグリッドラインを記述します。
CLK0の信号名上でダブルクリックし
シグナルプロパティ・ダイアログボックスを開きます。
ダイアログ上部の[Grid Lines]ボタンをクリックし
Grid Optionsダイアログを開きます。
Enable Gridのラジオ・ボタンにチェックを入れます。
各数値を入力し[OK]または[Apply]ボタンをクリッ
クします。
グリッドラインが記述されました。
44
InterLink
グリッドラインの記述2
・Grid Options ダイアログについて
Where To Draw Grid
[Enable Grid] ラジオボタン グリッドラインのオン・オフ
[Use Min Edge] ラジオボタン
変化点のエッジの最小点か最大点の
どちらにグリッドラインを記述するか選択する
始めのグリッドラインが記述される
[Starting Event #:]
波形変化点
[Ending Event #:]
最後のグリッドラインが記述される
波形変化点
[Events Per Line:]
いくつの波形変化点ごとに
グリッドラインを記述するかの指定
How to Draw Grid
[Grid Line Style]
グリッドラインの種類の選択
[Grid Color]
グリッドラインの色の選択
[Starting signal]
[Ending Signal]
グリッドラインの長さの設定。
前項の図ではFirst Signal(CLK0)
からSIG0まで。
45
InterLink
タイムコンプレスマーカーの記述
―Time break―
モードボタンの[Maker]をクリックする。
ダイアグラム内で右クリックしMarkを記述します。
マーカーの名前、またはマーカーラインをダブルクリックして
エディットタイムマーカーダイアログを開く。
[Type:]のプルダウンボックスからTime break(curve)を選択する。
コンプレスする時間の長さ(Time break compresses time by ;)、
マーカーを記述する時間(Attached to time;)を指定し[OK]をクリックする。
50ns(Markerの位置)から200nsの区間が非表示になりました。
46
InterLink
プリントについて
MS-Word 、PowerPointへの波形貼り付け
対応フォーマット
• Windowsメタファイル(.wfm)、フレームメーカMIF
ファイル、EPSファイル、CGMファイル、EMFファイル
• TIFF、PNG、JPEGはDataSheet Proで対応
47
InterLink
MS-Wordへの波形貼り付け例
Windowsメタファイルでの例
OLE機能
※WaveFormer Proでは、
オプション機能として
追加が必要
48
InterLink
PowerPointへの波形貼り付け例
0 ns
5 00
2 .0 us
2 .5
4 .0 us
c lk
SAMPLE2
id at a[ 31 :0 ]
id at a_ v alid
P1
O
If
ida ta _v alid =Va lid (1 )
v a lid
If
id at a_ ac k
P 2 / C2
v a lid
ida ta _v alid =Va lid (1 ) th en
O
a ck
a ck
1 8 clo ck ( m in .)
1 c loc k (c o ns t)
ik ey [ 31 :0 ]
ik ey _ v alid
m o de
O
O
SAMPLE1
K 2 / n ot hin g
K 1 / no th ing
val / i nval
val / i nval
Mod el
Mo de l1 / 2
O
p ro ce ss : 1 6c loc k (c o ns t. )
L at en cy : 1 8 clo ck ( c on st .)
C1
o da ta [3 1: 0 ]
o da ta _e n
e na bl e
1 c loc k (c o ns t. )
^
^
D at a in p u
D at a o u tp u t
Ctal cu l at io n
49
C2 / P2
e na bl e
InterLink
WaveFormerのインポート/エクスポート機能
50
InterLink
WaveFormerのインポート/エクスポート
機能(続き)
WaveFormer ProへImport可能なファイルフォーマット
Timing Project(*.btim,*.tim)
TDML(*.tdml,*.tdm)
Free Parm(*.fp)
Text Free Parm(*.txt)
Value Change Dump(*.dump,*.vcd)
SpeedWave VHDL(*.vwt,*.vcd)
WorkView WFM(*.wfm)
Agilent Fast Binary Out(*.bin)
Agilent Logic Analyzer(*.hpl)
Agilent Wave Logic Analyzer(*.hwl
)
Agilent Infinium Digitizing
Oscilloscope(*.txt)
Agilent LogicWave Analyzer(*.csv)
Podalyzer Data(*.dat)
PeakVHDL AWF(*.awf)
DesignWorks(*.tim)
TimingDesigner(*.td,*.tl)
Test Vector Spreadsheet(*.txt)
Tectronix Logic Analyzer(*.txt)
Protel Advanced PLD(*.wvf)
AWF(*.awf)
Aldec VHDL Waves Vectors(*.vec)
Altera table format(*.tbl)
German format(*.ger)
Spice CSDF Format(*.csd)
Synopsys TimeMill(*.out)
51
InterLink
WaveFormerのインポート/エクスポート
機能(続き)
WaveFormer ProからExport可能なファイルフォーマット
Timing Project(*.btim,*.tim)
TDML(*.tdml,*.tdm)
Free Parm(*.fp)
Text Free Parm(*.txt)
Workview CMD(*.cmd)
Mentor QuickSimⅡ(*.f)
VHDL(*.vhd)
Verilog(*.v)
Spice source(*.cir)
Hspice source(*.cir)
Pspice digital(*.fst)
Abel stimulus(*.abv)
Minc PLD-Designer(*.stm)
Agilent Pattern Generator disk
(*.hpd)
Agilent Pattern Generator bus(*.hpb)
Agilent Pattern Generator binary
(*.pgb)
PI-2005 Pattern Generator(*.txt)
STIL Test Vectors(*.stl)
Altera Vector Format Binary(*.vec)
Altera Vector Format Hex(*.vec)
PLA Format(*.pla)
Modelsim Force File(*.sim)
Test Vector Spreadsheet(*.txt)
Tektronix Test Vector(*.txt)
Logic Express stimulus(*.txt)
52
InterLink
計測器データのインポート/エクスポート
(続き)
53
InterLink
計測器データのインポート/エクスポート
(続き)
実機動作検証 - シミュレータの入力波形を実機への入力信号に、
出力波形は期待値としてサンプリングした信号と比較
シミュレーション結果と
実機データをマージして
同一信号名を自動比較し
差異をハイライト
WaveFormer Pro
で入力信号を変換
シミュレーション結果
(VHDL / Verilog・・・)
実チップ(またはボード)
パタン・ジェネレータ
マージ
マージ
WaveFormer へ
比較
実機からのデータを
WaveFormer Pro/VeriLogger Pro
へ読み込み
ロジック・アナライザ
54
InterLink
波形からVerilogパタ-ンの生成
波形
。。。(略)。。。
。。。(略)。。。
module stimulus(CLK0, SIG0, SIG1, SIG2);
begin
Verilog
output CLK0;
#50.0;
output SIG0;
SIG2_driver <= 1'b0;
output [3:0] SIG1;
#50.0;
output SIG2;
SIG0_driver <= 1'b1;
reg SIG0_driver;
SIG1_driver <= 4'h8;
。。。(略)。。。
。。。(略)。。。
55
InterLink
HDLスティミュラスパターン生成時の注意
エクポートする際[Signal properties] ダイアログのDirectionプルダウンボ
ックスから各信号の入出力方向を指定しますが注意点があります。
テストベンチの立場での信号の向きを
指定する必要があります。
すなわち、
MUT(Model Under Test)のスティミュラスと
なるテストベンチの信号は出力となります。
MUTの出力信号に対しては、テストベンチが
受け取り側となるので入力となります。
MUTの立場で設定し、入出力設定を逆にすると
正しいテストベンチ出力を得られません。
右は、4ビットadderのテストスティミュラス
作成のためのタイミングダイアグラムです。
信号x,y,c_inは回路図ではinputになり、
信号sum,c_outはoutputになります。
しかしテストスティミュラス作成時は、
信号x,y,c_inをoutput、
信号sum,c_outをinputに設定します。
56
InterLink
大規模ファイルの取り扱い
GigaWave機能
WaveFormer Proでは、オプション機能として追加が必要
WaveFormer Pro Gseriesでは標準装備
GigaWave オプションが無い場合、信号数 10000、あるいは、
信号波形エッジ数 150万 のどちらか最初が認識された際、制約にかかります。
 一方、GigaWave オプションが有る場合、上記制限はありません。
(プログラムとしては無制限です)
57
InterLink
波形比較
波形比較(Comparison)機能
WaveFormer Proでは、オプション機能として追加が必要
WaveFormer Pro Gserisでは標準装備
58
InterLink
波形比較1
・信号を個別に比較する。
信号名をSIG1からSIG0へ
変更します。
下図のSIG0とSIG1を比較します。
(SIG0を参照信号、SIG1比較信号とします)
SIG1のSignal Properties ダイアログボックスを開きます。
まず、信号名をSIG1から参照信号と同じSIG0とします。
(比較する信号同士は同じ信号名にする必要があります。)
そして[Compare]のラジオボタンにチェックをいれます、すると….
比較信号にはトレランス値(差分
許容値)を設定できます。これに
より比較に幅をもたせることがで
きます。
2信号間で検出された波形値のことなる部分が
波形上に赤色表示されあます。 (トレランス=0)
トレランス+3で比較した結果、
80ns以降の差分以外が解消
されています。
59
InterLink
波形比較2
・波形同士を比較する
下図の波形(Aとします)を参照波形とし他の波形と比較します。
A
メニュー[File]→[Compare Timing Diagram…]で比較したい任意の
波形ファイル(Timing file ,(*btim,*btm))(Bとします)を取り込みます。
A
B
始めからあった波形Aと[Compare Timing Diagram…]で取り込んだ波形Bが
比較さた波形ダイアグラムが表示されます。
60
InterLink
波形比較3
・すべての信号のプロパティを変更する。
すべての信号のトレランス値を変更したい場合などはツールバーにある[SET ALL] ボタンを
使うと全ての信号が選択された状態で[Signal properties] ダイアログが開きます。
・波形比較の不一致レポート
(1)[Report 」ウィンドウの[Differences]タブ
(2) 作業フォルダ下に保存されるタブ区切りフォーマットのテキストファイル
(3)波形上のグラフィカル表示
61
InterLink
アナログ波形
WaveFormer Proは、デジタル波形のみならず、アナログ波形もサポートしています。
このアナログ波形サポート機能により、デジタル信号→アナログ信号の変換、
またその逆変換なども可能となります。
(詳しくは「アナログシグナル操作ガイド」をご覧下さい。)
62
InterLink
InterLink
有限会社 インターリンク
231-0023 横浜市中区山下町 252 グランベル横浜9F
TEL:045-663-5940 FAX:045-663-5945
[email protected] http://www.ilink.co.jp
*本資料の無断複製・転載を禁じます。
63
InterLink
ダウンロード

信号波形の編集1